現象
Next Design の起動時にエラーメッセージが表示され、アプリケーションを起動できない場合があります。
原因
操作や起動の仕方によって問題の原因も様々ですが、次の原因が考えられます。
- アプリケーションが読み込むファイルの不正/破損
- 必要環境の不足/間違い
- セキュリティによる保護
これらの原因に対して以下に対策を示します。 以下の順に対策を試みていただき、起動できるようになるか確認しながら進めてください。
対策
(1) ユーザー設定ファイルを削除する
※ V1.1以降をご利用の方は本対応不要です。
次のパスに格納されている usersettings.json ファイルを削除後に、Next Designを起動してください。
- {ユーザーのホームパス}\AppData\Local\DENSO CREATE\Next Design\user\usersettings.json
ユーザーのホームパスの例: C:\Users\user-name
注意: 上記の {ユーザーのホームパス}\AppData フォルダは隠しフォルダです。
エクスプローラからアクセスするには、アドレスバーに直接入力するか、 エクスプローラのリボンから [表示] > [表示/非表示] > [隠しファイル] チェックボックスを ON にしてください。補足: 上記ユーザー設定ファイルに格納されている情報は次の通りです。 削除するとこれらがリセットされます。
・リポジトリ登録情報などの構成管理連携機能の設定
・オプションの表示言語設定
(2) キャッシュ情報ファイルを削除する
※ V1.1以降をご利用の方は本対応不要です。
次のフォルダを削除後に、Next Designを起動してください。
- {ユーザーのホームパス}\AppData\Local\DENSO CREATE\Next Design\user\cache\
補足: 上記フォルダに格納されているキャッシュ情報は次の通りです。削除するとこれらがリセットされます。
・最近開いたプロジェクト
・ウィンドウのサイズ・表示位置、エディタの表示幅
・プロジェクトで最後に表示していたモデルやツリーの展開状態
(3) OSのパフォーマンスモニターを復旧する
※ V1.1以降をご利用の方は本対応不要です。
OSのパフォーマンスモニターが正常動作しているか確認してください。
確認方法は、Windowsの [スタートメニュー] > [Windows 管理者ツール] > [パフォーマンス モニター] を起動し、 左のリストに [パフォーマンス] > [モニター ツール] > [パフォーマンス モニター] の項目が存在するかご確認ください。
さらに、[パフォーマンス モニター] の項目を選択し、モニター画面が表示されれば正常動作しています。
もし、パフォーマンスモニターの項目が存在しない(表示できない)場合は、 次のページを参考に「パフォーマンスカウンタの再構築」の1~4の手順を試みてください。
https://learn.microsoft.com/ja-jp/troubleshoot/windows-server/performance/manually-rebuild-performance-counters#rebuild-all-performance-counters-including-extensible-and-third-party-counters
(4) 必須環境のインストール状態を確認する
コントロールパネルの「プログラムと機能」から、下記対象およびバージョンがインストールされていることを確認してください。
インストールされていない場合は、下記のものをインストールしてください。 (Next Designのインストーラを起動し、必要なものを選択してインストールすることもできます)
-
Next Design V2.0 の場合
- .NET Core: 3.1.10 以降
- .NET Framework: 4.6.2 以降
- VC++2010 Redistributable (10.0.40219)
- VC++2015 Redistributable (14.0.24212.0)
-
Next Design V1.1 の場合
- .NET Framework: 4.6.2 以降
- VC++2010 Redistributable (10.0.40219)
- VC++2013 Redistributable (12.0.40649.5)
- VC++2015 Redistributable (14.0.24212.0)
(5) エクステンションを確認する
エクステンションが影響し、起動できない可能性があります。
エクステンションの格納先フォルダを空にし、エクステンションが読み込まれないようにした上で、Next Design を起動してください。
特に指定していない限り、エクステンションは次のフォルダ以下に格納されています。 これらのフォルダが存在する場合は、そのフォルダ内のファイルおよびサブフォルダを削除してください。
- {Next Design インストールフォルダ}\extensions
- {ユーザーのホームパス}\AppData\Local\DENSO CREATE\Next Design\extensions
- {ユーザーのホームパス}\AppData\Local\DENSO CREATE\Next Design\installed-packages
- C:\ProgramData\DENSO CREATE\Next Design\extensions
既定の Next Design インストールフォルダ: C:\Program Files (x86)\DENSO CREATE\Next Design
ユーザーのホームパスの例: C:\Users\user-name
これらのフォルダ内を空にして起動できた場合、エクステンションに問題があります。
エクステンションの発行元にお問い合わせください。
補足: 上記の {ユーザーのホームパス}\AppData フォルダと C:\ProgramData フォルダは隠しフォルダです。
エクスプローラからアクセスするには、アドレスバーに直接入力するか、 エクスプローラのリボンから [表示] > [表示/非表示] > [隠しファイル] チェックボックスを ON にしてください。
(6) 動作環境を確認し、適合する環境でご利用いただく
OSおよび連携アプリケーションのバージョンが動作保証環境外である可能性があります。
保証環境の詳細は、下記を参照してください。
(7) セキュリティソフトを終了した上で、アプリケーションを起動する
セキュリティ違反などの誤検知により、必要なファイルにアクセスできず読み込めない場合が稀にあります。
セキュリティソフトウェアなどの他アプリを終了し、Next Design を起動してください。
(8) Next Designインストーラを使用してインストールする
Next Designインストーラを使用せずにインストールした場合、 特にZip圧縮ファイルを解凍して入手したexeやDLLファイルを利用している場合、 解凍時に「ブロック解除」しないと、OSのセキュリティ違反によりDLLが読み込めない場合があります。
既存の Next Design 一式を削除した上で、インストーラで Next Design をインストールしてご利用ください。
(9) 管理者権限を付与して起動する
管理者権限がないため、アプリケーションが必要なファイルを読み込めず起動できない可能性があります。
ログインユーザーに管理者権限を権限を付与して Next Design を起動してください。
問題が解決しない場合
上記(1)~(9)の対策でも問題が解決しない場合は、テクニカルサポートへお問い合わせください。
問題があった場合、アプリケーションがログファイルを出力する場合があります。 次のフォルダをご確認いただき、ログファイル(.log)があれば、テクニカルサポート(ndsupport@denso-create.jp)までファイル送付いただけると、問題解消がスムーズに進む可能性があります。
- {ユーザーのホームパス}\AppData\Local\DENSO CREATE\Next Design\logs
ユーザーのホームパスの例: C:\Users\user-name
補足: 上記の {ユーザーのホームパス}\AppData フォルダは隠しフォルダです。
エクスプローラからアクセスするには、アドレスバーに直接入力するか、 エクスプローラのリボンから [表示] > [表示/非表示] > [隠しファイル] チェックボックスを ON にしてください。
なお、ログファイルには、お客様の個人情報・設計情報は一切含まれません。