オンラインでのライセンス登録に失敗する。

 

現象

オンラインでライセンス登録を行う際に、次のエラーメッセージが表示されて失敗する場合があります。

registration-error.png

原因

ネットワーク構成は多様なため問題の原因も様々ですが、次の原因が考えられます。

  • Firewall でインターネットへのアクセスが制限されている場合 ・・・ 対策(1)
  • 特定のプロキシを指定する必要がある場合 ・・・ 対策(2)
  • プロキシサーバーによる転送情報が不十分な場合 ・・・ 対策(3)

これらの原因に対して以下に対策を示します。以下の順に対策を試みてください。
それでも問題解決しない場合はテクニカルサポートへお問い合わせください。

対策

(1) Firewall の設定確認

Firewall でライセンス認証サーバーへのインターネット接続が許可されている必要があります。次の "Firewall whitelisting" の情報に従って、指定 IP アドレスに向けた接続が許可されていることをご確認ください。

https://docs.cryptlex.com/node-locked-licenses/proxies-and-firewall#firewall-whitelisting

詳しくは、ネットワーク管理者にご確認ください。

(2) プロキシの設定

オンラインでライセンス登録する際には、次のURLにアクセスできる必要があります。

https://api.cryptlex.com/v3/activations

ブラウザで上記URLにアクセスして、次のように表示されれば問題なくアクセスできています。

{"message":"Authentication failed! The request must include a valid and non-expired bearer token in the \u0027Authorization\u0027 header."}

上記URLにアクセスするために特定のプロキシを指定する必要がある場合は、次の方法でプロキシを設定してからライセンス登録を行ってください。

  1. [ライセンスの登録] ダイアログの下側に表示されている [ネットワークの設定] リンクをクリックして、[ネットワーク接続情報] ダイアログを開きます。
  2. [プロキシを使用する] チェックボックスを ON にし、[サーバーアドレス] の他、プロキシ利用時に必要な情報を入力して [OK] ボタンを押下します。
    なお、[サーバーアドレス] の値には "http(s)://" を付けず、サーバーの FQDN もしくは IP アドレスを指定してください。
    (プロキシ設定の詳細については、ネットワーク管理者にお問い合わせください)
  3. [ライセンスの登録] ダイアログに戻り、[プロダクトキー] と [メールアドレス] を入力して、[登録] ボタンを押下します。

mceclip0.png

(3) プロキシサーバーの設定確認

オンラインでのライセンス登録時、ネットワーク通信において「100-Continue」のHTTPリクエストヘッダによる通信を行います。HTTP/1.0対応のプロキシサーバーの場合、そのヘッダが正しく転送されずライセンス登録に失敗する場合があります。その場合は、次のいずれかの対応が必要になります。

  • 100-Continueをスルーするようプロキシサーバーを設定する
  • HTTP/1.1対応のプロキシサーバーにアップグレードする

詳しくは、ネットワーク管理者にご確認ください。

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