現象
[拡張機能の管理] ダイアログの [デンソークリエイト公式] パッケージソースを選択すると、パッケージ一覧に「データがありません。」と表示される場合があります。
原因
ネットワーク構成は多様なため問題の原因も様々ですが、次の原因が考えられます。
- 特定のプロキシを指定する必要がある場合 ・・・ 対策(1)
- プロキシサーバーによる転送情報が不十分な場合 ・・・ 対策(2)
これらの原因に対して以下に対策を示します。以下の順に対策を試みてください。 それでも問題解決しない場合はテクニカルサポートへお問い合わせください。
補足:
ライセンス登録時に表示される [ライセンスの登録] ダイアログにもプロキシ設定の項目がありますが、拡張機能の管理で参照しているプロキシ設定とは異なります。
そのため、同じ内容のプロキシ設定であっても、拡張機能の管理側でもプロキシの設定が必要です。
対策
(1) プロキシの設定
拡張機能の管理ダイアログの [デンソークリエイト公式] パッケージ一覧を取得するには、次のURLにアクセスできる必要があります。
https://nextdesign-packages.azurewebsites.net
ブラウザで上記URLにアクセスして、次のように表示されれば問題なくアクセスできています。
You are running NuGet.Server v*.*.*.*
上記URLにアクセスするために特定のプロキシを指定する必要がある場合は、次の方法でプロキシを設定してからライセンス登録を行ってください。
- [拡張機能の管理] ダイアログの下側に表示されている [設定] リンクをクリックして、[拡張機能の設定] ダイアログを開きます。
- [拡張機能の設定] ダイアログの下側に表示されている [設定] リンクをクリックして、[ネットワークの設定] ダイアログを開きます。
- [プロキシを使用する] チェックボックスを ON にし、[サーバーアドレス] の他、プロキシ利用時に必要な情報を入力して [OK] ボタンを押下します。 (プロキシ設定の詳細については、ネットワーク管理者にお問い合わせください)
- [拡張機能の設定] ダイアログに戻り、[OK] ボタンを押下します。
[サーバーアドレス] の値には "http(s)://" を付けず、サーバーの FQDN もしくは IP アドレスを指定してください。
(2) プロキシサーバーの設定確認
オンラインでのライセンス登録時、ネットワーク通信において「100-Continue」のHTTPリクエストヘッダによる通信を行います。HTTP/1.0対応のプロキシサーバーの場合、そのヘッダが正しく転送されずライセンス登録に失敗する場合があります。その場合は、次のいずれかの対応が必要になります。
100-Continueをスルーするようプロキシサーバーを設定する HTTP/1.1対応のプロキシサーバーにアップグレードする
詳しくは、ネットワーク管理者にご確認ください。